NEW SECTRET UPDATE COMING
Incident Report for Techsupport123
Update
we are currently updating live chat
Posted Sep 02, 2020 - 20:44 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 02, 2020 - 20:44 UTC
This incident affects: Live chat.